Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

ADM: Could not connect to HTTP invoker remote service

SA-23245

Summary



Developer successfully configured and installed Adaptive Decision Manager (ADM), and could ping the ADM Service through the Decisioning Services screen and can see that the ADM Service is up and reachable but facing the ConnectException during startup. The ADM Service is embedded but the Embedded Process option is not available and need to enter the hostname and the port details even the process is embedded.

Error Messages



Could not connect to HTTP invoker remote service at <ip address>; nested exception is java.net.ConnectException: Connection refused

Steps to Reproduce



Restarted the JVM.


Root Cause



This is an expected behavior - users are not allowed to use Embedded process of ADM in a Pre-Production (productionLevel = 4) or Production (productionLevel = 5) environments.


Resolution



Developer must be able to select the Embedded Process option for ADM in any other environment in which productionLevel is less than 4.

With regard to the “Connection refused” error, it can be observed when Agents from the PRPC node tries to connect to the ADM Service before the ADM server is up and running during the server start-up. This error message can be ignored.

Published May 19, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us