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Support Article

After updating to Pega 7.1.7 an agent schedule remains deleted

SA-23401

Summary



After updating to Pega 7.1.7, an agent schedule appears to be deleted in the Designer Studio. The deleted agent schedule persists even after restarting the node, and it is not possible to delete it using Designer Studio. If an agent schedule is missing, then the system should create it by copying information from the associated agent's rule. However, that does not happen.

Error Messages



Not Applicable

Steps to Reproduce

  1. Update to Pega 7.1.7.
  2. Delete an agent schedule.
  3. Restart the node. The agent schedule continues to show up as deleted and is not automatically recreated.

Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Perform the following local-change:
  1. Back up complete database or at least back up PR_DATA table.
  2. Shut down the nodes.
  3. In the database, delete from PR_DATA where pzInsKey = '<actual_pzInsKey_value' (for the affected agent schedule rules for the affected nodes).
  4. Start up the nodes.
  5. Ensure the agent schedules have been properly recreated.
  6. Make sure all the agents in the System Management Application (SMA) are correct and the "Next run time" column is correct. "Exception info" column must be blank.

Published May 21, 2016 - Updated October 8, 2020

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