Support Article
Agent queue items fail due to authentication errors
SA-28652
Summary
The user has recycled the JVM after applying maintenance Hfixes and now the Agent execution fails with error. The Agent rule has 'Bypass activity authentication' box checked and this used to work correctly before applying Hfix-25542.
Error Messages
2016-09-25 05:00:22,426 [PegaRULES-Batch-6173] ( engine.runtime.Executable) ERROR - Only authenticated client may start this activity: RULE-OBJ-ACTIVITY @BASECLASS LOOKUPLIST #20070314T090210.050 GMT
com.pega.pegarules.pub.PRRuntimeException: Error: You lack access required to execute RULE-OBJ-ACTIVITY @BASECLASS LOOKUPLIST #20070314T090210.050 GMT
Steps to Reproduce
Not Applicable
Root Cause
A defect or configuration issue in the operating environment. Despite having 'Bypass activity authentication' box checked, the setting doesn't seem to be taking effect.
Resolution
Perform the following local-change: Explicitly click 'Save' on the Agent Rule with 'Bypass activity authentication' box checked and then try to run the Agent again. The following article gives more insight into how this works - https://pdn.pega.com/agent-processing-throwing-exception-when-run-activity
Published November 4, 2016 - Updated October 8, 2020
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