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Support Article

Agent Schedule does not get created automatically in Pega 7

SA-10978

Summary



User has created an Agent in their application built on Pega 7 platform.
Ideally the schedule must be created automatically. However, the Agent schedule is not getting created automatically and hence user cannot schedule that agent.


Error Messages



Not Applicable.

Steps to Reproduce



Search Agent Schedule record and Agent outlook.
User can witness that it is not available. 

Root Cause



The root cause of this problem is defect/misconfiguration in the operating environment.

It seems as master agent is failing for creating the Data-Agent-Queue, other agent schedules are also failing. After checking the specific agent setting on analysing the logs Pega was able to find the correct Agent name.

Pega also found that Agent is recurring and on clicking Advanced tab, user can view the time configuration error.




Resolution



This issue is resolved through the following local-change: 
 
Re-save the Agent rule and restart the system. You can notice that Issue is fixed and Agent schedule occurs properly.

Published July 10, 2015 - Updated October 8, 2020

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