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Support Article

Agent SystemCleaner reschedule gets "Invalid delay interval"

SA-11464

Summary



When setting up a new AES server in our production environment.
You are using PRPC 7.1.7 (BuildName coreAssemblyCached_717_644) and AES 7.1.
The following AES hotfixes are installed: HFix-9476.jar, HFix-9623.jar, PegaAESDataUtilityObject.zip, HFix-9570.zip, and pxHFix-9842.jar.

PRPC 7.1.7 and AES 7.1 are up and running.
But during the deployment validation of the new AES production instance you have detected that the Agent SystemCleaner was terminated due to an error that was logged in the PegaRULES log file during the rescheduling of the agent.

Weblogic server 10.3
Oracle 11.2
Sun java 1.6.0_75



Error Messages



2015-05-12 06:00:09,550 [fault (self-tuning)'] [ STANDARD] [ PegaRULES:07.10] ( internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -9301

2015-05-13 06:00:01,851 [fault (self-tuning)'] [ STANDARD] [ PegaRULES:07.10] ( internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -1607

2015-05-14 06:00:00,291 [fault (self-tuning)'] [ STANDARD] [ PegaRULES:07.10] ( internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -148


Steps to Reproduce



None. Please search for the string "internal.async.AgentQueue) ERROR" in the two attached log files.

Root Cause



It happens when an agent is scheduled to run at 12:00:00 midnight; if it ends up being scheduled to run even a second prior to that, it would be the previous day in regards to the agent timezone that results in negative value in time calculation (Next Execution Time - Current Time).


Resolution



Changing the agent to run 5 minutes later resolves the issue.

 

Published February 20, 2016 - Updated October 8, 2020

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