Support Article
Application gets stuck while launching a new case worker portal
SA-50659
Summary
Case worker portal's dashboard is getting launched properly if user logs off using "Log Off" menu.
This action gets stuck if user closes it from browser's close button and launches again.
Error Messages
Not Applicable
Steps to Reproduce
1. Launch Case worker portal from Launch portal menu.
2. Close the portal and launch it again from launch portal menu.
3. Notice the screen loads for more time and not able to perform any action, unless log off and relaunch of the portal is done.
Root Cause
A defect or configuration issue in the operating environment.
Actions tab in sub menu of manager portal is not properly configured due to that value of busy indicator is set to true always.
Resolution
Perform the following local-change steps:
1. Open pyCaseManagerLinks of "Data-Portal" class.
2. Select "MyWorkList" label and open actions.
3. Remove harness from action tab.
4. Add an action :Run Script and include below parameters and set few of their values as mentioned:
Function Name :"pega.desktop.showHarness"
tabName :"My Worklist"
className:"Data-Portal"
harnessName:"pyMyWorkList"
preActivityName
preActivityParams
keyValue
readOnly
preDataTransformName
replaceCurrent
skipConflictCheck
contentID
dynamicContainerID
skipReload :"true"
tabName :"My Worklist"
className:"Data-Portal"
harnessName:"pyMyWorkList"
preActivityName
preActivityParams
keyValue
readOnly
preDataTransformName
replaceCurrent
skipConflictCheck
contentID
dynamicContainerID
skipReload :"true"
Published April 20, 2018 - Updated October 8, 2020
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