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Support Article

"Caught exception during autocommit check" error in broken queue

SA-30593

Summary



In a Pega deployment running on WebSphere Application Server, queue items are occassionally going to the broken item queue with an autocommit error.


Error Messages



caught exception during autocommit check


Steps to Reproduce



Send a case for SLA agent processing that has Advanced Flow action configured.


Root Cause



A configuration issue in the operating environment
WebSphere Application Server is not checking that the JDBC connection is closed. When Pega attempts to use the closed connection, an error is encountered.

Resolution



Perform the following local-change.
Set WebSphere Application Server to check that the connection is still valid. The exact steps depend on the version of WebSphere Application Server.
These are the steps for WebSphere Application Server Version 8.
  1. In the WebSphere Admin Console, go to Resources > JDBC > Data Sources.
  2. On the Data Sources page, go to <name of Pega data source>.
  3. On the Pega data source page, go to WebSphere Application Server data source properties on the right-side of the screen.
  4. Under Connection Validation Properties, select the options Validate new connections and Validate existing pooled connections.
  5. Under Validation Options, enter a query.
    By default, use "SELECT * FROM DUAL".
    This query runs in constant time and should have no noticeable effects on performance.

Published November 16, 2017 - Updated October 8, 2020

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