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Support Article

Elastic Search issues with work and rules.

SA-17948

Summary



After PRPC 6.2SP2 to PRPC 7.1.8 upgrade, many rules cannot be found with the search textarea. Node id in the Search index host node settings was incorrect. Only new created rules can be found.

In Search Page (Designer Studio->System->Settings->Search) when checking Work index files, file seems to be corrupted yet not problems are seen with workobject.

 

Error Messages




2015-12-08 08:33:05,216 [ PegaRULES-Batch-3] [ STANDARD] [ ] [ PegaRULES:07.10] (nal.es.DistributedIndexerAgent) ERROR - Incremental indexing of 'WORK' entries failed: Indexing request failed. Please contact your system administrator.. Please contact your PegaRULES system administrator.

2015-12-08 08:37:06,346 [ PegaRULES-Batch-3] [ STANDARD] [ ] [ PegaRULES:07.10] (nal.es.DistributedIndexerAgent) ERROR - Incremental indexing of 'WORK' entries failed: Indexing request failed. Please contact your system administrator.. Please contact your PegaRULES system administrator.

2015-12-08 08:48:07,950 [ PegaRULES-Batch-4] [ STANDARD] [ ] [ PegaRULES:07.10] (nal.es.DistributedIndexerAgent) ERROR - Incremental indexing of 'WORK' entries failed: Indexing request failed. Please contact your system administrator.. Please contact your PegaRULES system administrator.


Steps to Reproduce


1) Connect to Designer Studio.
2) In search text area looking for some rule (exemple a SOAP service named handleARP)
3) No rules found.
4) Go to records->Integration Services->SOAP services
5) In Method Contains Text Area look for handleARP
6) Rule is found.


Root Cause



The database was created from an export from another environment, which had old information in the tables that was causing the Elastic search to fail.

Resolution



There appears to be issues with elastic search when a databased is cloned from an old one, in this case the imported database dump of an old environment triggered this issue.

The following config settings must be set to true in order for elastic search to be used:
 
  • indexing/distributed/enabled
  • indexing/distributed/index_enabled
  • indexing/distributed/search_enabled
 

Also because the database was cloned from another database the following actions need to be carried out:

1. Please make sure the 3 DSS settings above are enabled.

2. Stop all the nodes

3. Truncate pr_sys_statusnodes table
4. Remove the index files from all the nodes.
5. Restart the nodes and configure everything again in the search landing page.
6. Reindex RULES, DATA and WORK again from the landing page (not SMA)

This resolved the issue.

 

Published January 31, 2016 - Updated October 8, 2020

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