Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error when using product migration command line utility

SA-9513

Summary



While testing the product migration utility, an error is encountered during the migrate action for migrating products to a target system. All the other actions are working as expected. 
Migrate action used:


./productMigration.sh migrate -url http://server:8080/prweb/PRSOAPServlet -user [email protected] -pwd rules -targets server -products MigrationTest:01.01.01

Error Messages



PegaRULES Product Migration: Target System server Returned: Target system was unable to download the archive file because of an IOException: java.io.IOException: Server returned HTTP response code: 401 for URL: http://server:8080/prweb/DiagnosticData?path=StaticContent/global/ServiceExport/MigrationTest_01.01.01.zip

Steps to Reproduce



Not Applicable

Root Cause



The target system is unable to access the /DiagnosticData directory to gather the zip file.

Resolution



PegaDiagnosticUser is used for this process and part of the setup for this utility is to create a Data-Admin-System-Security instance for PegaDiagnosticUser. In this case, the password being specified in the Data-Admin-System-Security is incorrect. Updating the password resolves the issue.

Published June 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us