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Support Article

Followed Case does not appear in Following Panel

SA-21171

Summary



When user clicks the follow/unfollow button in quick succession then the case eventually does not appear in the follow panel on the left hand side of the dashboard.

On further investigation, the it was discovered that the record is not being written to Index-WorkPartyUri. 
Issue is sporadic.

Error Messages



Not Applicable

Steps to Reproduce



1.Create a case on a Case manager
2.Follow the work object.
3.Click Follow/unfollow icon triple time in short time. Retry again.
4. See the list of follow list missing the work object followed.

Root Cause



A defect in Pegasystems’ rules.
Pega-EndUserUI - RULE-OBJ-ACTIVITY WORK- PZADDFOLLOWERWORKPARTY
Pega-EndUserUI - RULE-OBJ-ACTIVITY WORK- PZREMOVEFOLLOWERWORKPARTY
The issue is with the declare indexes are not being generated correctly because of some metadata missing while doing a page copy.
The metadata from the workparty page is copied but not the metadata on the workpage. Copy the indexcount from the db workpage to clipboard workpage to make it work.


Resolution



Apply Hotfix-26218

Published March 23, 2016 - Updated October 8, 2020

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