Support Article
Pega 7.1.7 does not restart after changing the SystemName
SA-8411
Summary
You changed the SystemName via DSS. Pega 7.1.7 system now fails to start.
Error Messages
Not Applicable
Steps to Reproduce
Change the SystemName in prconfig / DSS and restart the PRPC node.
Root Cause
The SystemName was changed but the corresponding Requestor Types were not created.
Resolution
Issue was resolved after following changes were made in the system:
prconfig.xml was updated with old system name by adding the below. This bought the server up.
<env name="identification/systemName" value="pega" />
When you change SystemName, each system requires at least four Requestor Types: App, Batch, Browser, and Portal. You can copy the existing Requestor Types in the default 'pega' system.
After this, the new system name was added to prconfig.xml file and server came up fine. Few issues around Search Re-indexing were reported. DSS for indexing were reviewed and proper node ID was identified (from pxProcess --> pxSystemNodeID) and updated.
Published April 22, 2015 - Updated October 8, 2020
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