Support Article
Pega 7.1.9 does not allow Specialize by Circumstance
SA-21557
Summary
After installing Pega Customer Service 7.1.4 on Pega 7.1.9, you cannot circumstance Pega-provided rules. This is because the Customer Process Manager (CPM) ruleset has rules that are already circumstanced in the CPM ruleset.
When a Pega-provided rule with the same name is "Save As (Specialize by circumstance) " it conflicts with that of the CPM ruleset even though there is no dependecy between the rulesets.
Error Messages
pyCircumstanceProp:
This rule already has a circumstance property defined (CPMPortalType); you cannot give it another.
This rule already has a circumstance property defined (MobileDevice); you cannot give it another.
Steps to Reproduce
1. Install Customer Service 7.1.4 on Pega 7.1.9.
2. Log in to an application having no dependency on the CPM ruleset.
3. Try to "Save As (Specialize by circumstance)” the Pega-provded Work- .Perform harness rule.
4. See the error.
Root Cause
This is a known limitation of Pega 7.1.9: It does not allow creation of circumstanced rules with different properties even in the case when the two rules are in different rulesets or applications. These validations have been relaxed in Pega 7.2.1.
Resolution
Apply HFix-25429.
Published June 3, 2016 - Updated October 8, 2020
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