Support Article
Performing developer actions throws unspecified error
SA-21479
Summary
Unable to open case stages in a newly installed instance on Oracle and WebLogic. An error appears on screen and exceptions are thrown in the PegaRULES log files.
Error Messages
Status fail
Message There has been an issue; please consult your system administrator
Problem invoking function: pega_wb_lookuplist.readFileAsPage--(String)
java.lang.ClassNotFoundException: com.pegarules.generated.readFileAsPage_071017_SiW_nNAJCjXQ7Jp_PS2DSw
at com.pega.pegarules.internal.bootstrap.phase2.PRBaseLoader.findClass(PRBaseLoader.java:312)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at com.pega.pegarules.internal.bootstrap.phase2.PRBaseLoader.loadClass(PRBaseLoader.java:237)
Steps to Reproduce
- Log in as a developer.
- Access an existing case type, and view the life cycle.
- Click an existing step within that case type.
Root Cause
The log file showed LibraryFunctionNotFoundException and ClassNotFoundException errors for a few different functions and libraries.
Resolution
Perform the following local-change and regenerate libraries.
- Open the System Management Application (SMA).
- Select Rule Utility Library Extractor from the Administration section.
- Click the Extract Libraries button. Do not enter any specific library names or rulesets. This will cause the system to regenerate all libraries.
Published March 29, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.