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Support Article

Presence Agent is not initialized

SA-24848

Summary



When an attempt is made to login into the CTI by clicking the phone icon the below error is occurring. The issue occurs on Google chrome but not on Internet Explorer.


Error Messages


Presence Agent is not loaded or initialized.


Steps to Reproduce

  1. Log into the Portal.
  2. Click the Phone icon on telephony toolbar.
  3. Fill all the required information in the pop up dialog and login.


Root Cause



This happens due to javascript timming issue because which the PegaCall EventHandler doesnot get initialized.

Due to failure of javascript object initialization the login ScreenPoPControl could pass workstationID parameter value login and the exception occurs.

Resolution



The issue has been fixed in PegaCall7.1.33 onwards.

 For version 7.1.32  apply the below local changes:

Resave the 
pega_cti_callEventHandler.js in the application ruleset by introducing the changes highlighted inb yellow :


 

Resave the ScreenPopControl rule in the application ruleset by introducing the changes highlighted in yellow color :

Published July 15, 2016 - Updated December 2, 2021

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