Support Article
Service request responded after 28 minutes
SA-972
Summary
Ticketing application had a DB outage two weeks back. During that outage time service requestes are processed after 28 minutes.It used to take only 2 sec. Problem here is consumer application has 20 sec timeout limit. If they didnt recieve response within 20 sec then they will put the request in queue and process after half an hour. During this DB outage, consumer got timeout error but PEGA application processed it and took 28 min. We would like to know how it got processed after 28 min.
Error Messages
Timeout error on Consumer side.
Steps to Reproduce
DB is down.
Consumer application tried to send a request to PEGA Ticketing application.
Root Cause
From the call stack, we can see that JDBC was waiting for a response from the database. By default, the driver will wait indefinitely.
Resolution
In order for the driver to timeout, set the timeout as explained in the link http://www-01.ibm.com/support/docview.wss?uid=swg1PM91941.
In short, create a customer property in WebSphere under the PegaRULES datasource with Name set to connectionProperties and value set to oracle.jdbc.ReadTimeout=180000.
Published June 12, 2015 - Updated October 8, 2020
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