Support Article
SMA node connect error: insufficient or empty credentials
SA-12183
SUMMARY
SMA does not connect either directly within JVM or via SOAP.
ERROR MESSAGES
SOAP:
Failed to get mbean name. objName: com.pega.PegaRULES:cell=hostnameCell01,id="6c242d9d8c0d54cff718fd29f6127f7d",name=com.pega.pegarules.management.internal.UppercasedCache,node=hostnameNode01,process=AES_POCs1,type=enterprise
Failed to get the attribute
ADMN0022E: Access is denied for the getName operation on enterprise MBean because of insufficient or empty credentials.
Direct within JVM:
Failed to get mbean name. objName: com.pega.PegaRULES:cell=hostnameCell01,id="6c242d9d8c0d54cff718fd29f6127f7d",name=com.pega.pegarules.management.internal.UppercasedCache,node=hostnameNode01,process=AES_POCs1,type=enterprise
Exception occured trying to invoke the getter on the MBean
ROOT CAUSE
The root cause of this problem is defect/misconfiguration in the operating environment.
RESOLUTION
This issue is resolved by making the following change to the operating environment:
If WebSphere Application Server's Global/Administrative Security is enabled in any environment, the "Local Connection" option in SMA will not work as this cannot transmit admin credentials. If Administrative security is enabled, then, "Remote Connection" option has to be selected.
Here is brief explanation of two options.
* Local Connection: Connects directly to the platform MBean server via java interface (doesn't travel over network). User can do this if SMA and PRPC have been deployed to the same server/running in the same JVM. Note: This cannot be used with WAS Administrative security enabled.
* Remote Connection: Connects to WAS's MBean server using the WAS admin client. User needs to specify the SOAP port for WebSphere (this BTW is not the port that PRServlet runs on) and the host name or IP Address of the node. This is the only the option with WAS Administrative security enabled.
SMA does not connect either directly within JVM or via SOAP.
ERROR MESSAGES
SOAP:
Failed to get mbean name. objName: com.pega.PegaRULES:cell=hostnameCell01,id="6c242d9d8c0d54cff718fd29f6127f7d",name=com.pega.pegarules.management.internal.UppercasedCache,node=hostnameNode01,process=AES_POCs1,type=enterprise
Failed to get the attribute
ADMN0022E: Access is denied for the getName operation on enterprise MBean because of insufficient or empty credentials.
Direct within JVM:
Failed to get mbean name. objName: com.pega.PegaRULES:cell=hostnameCell01,id="6c242d9d8c0d54cff718fd29f6127f7d",name=com.pega.pegarules.management.internal.UppercasedCache,node=hostnameNode01,process=AES_POCs1,type=enterprise
Exception occured trying to invoke the getter on the MBean
ROOT CAUSE
The root cause of this problem is defect/misconfiguration in the operating environment.
RESOLUTION
This issue is resolved by making the following change to the operating environment:
If WebSphere Application Server's Global/Administrative Security is enabled in any environment, the "Local Connection" option in SMA will not work as this cannot transmit admin credentials. If Administrative security is enabled, then, "Remote Connection" option has to be selected.
Here is brief explanation of two options.
* Local Connection: Connects directly to the platform MBean server via java interface (doesn't travel over network). User can do this if SMA and PRPC have been deployed to the same server/running in the same JVM. Note: This cannot be used with WAS Administrative security enabled.
* Remote Connection: Connects to WAS's MBean server using the WAS admin client. User needs to specify the SOAP port for WebSphere (this BTW is not the port that PRServlet runs on) and the host name or IP Address of the node. This is the only the option with WAS Administrative security enabled.
Published July 14, 2015 - Updated October 8, 2020
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