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Support Article

System is generating PegaCTI Log files in two different location

SA-26491

Summary



Pega Platform 7.1.9
Pega CS 7.1.4
Pega Call 7.1.33.832

PegaCTI Logs are being generated in two different locations in the Server at the same time.

Location1: Application Logs directory: /app/pega/pegauk-dev/logs/
Location2: WebSphere node level - /app/WAS/was85/profiles/fft-uk-shared1-dev-W85node1

extract from prlogging.xml -


<appender name="com.pega.pegacti" class="com.pega.pegarules.priv.util.DailySizeRollingFileAppenderPega">
<param name="FileNamePattern" value="'/app/pega/peguk-dev/logs/PegaCTI-'yyyy-MMM-dd'.log'"/>
<param name="MaxFileSize" value="500MB" />
<layout class="com.pega.apache.log4j.PatternLayout">
<param name="ConversionPattern" value="%d [%20.20t] (%30.30c{3}) %-5p %X{stack} %X{userid}- %m%n" />
</layout>
</appender>

<category name="com.pega.pegacti" additivity="false">
<priority value="debug"/>

<appender-ref ref="com.pega.pegacti"/>
</category>


Have gone through the support articles available on pdn and have tried all options suggested. And I have already updated the appender details for prlogging , however it didn’t resolve the issue


Error Messages



Not Applicable


Steps to Reproduce

  1. Alter prlogging to contain a DailyRollingFileAppender with file location for CTI logging.
  2. Start the CTIlink engine.
  3. Check the location where log file is generated.


Root Cause



The reason for the two log files is that the logging was enabled in both prlogging.xml and tool and settings under pega call

Resolution



Logging for CTI should be set via the application Designer Studio>Channel Services>PegaCall>Tools & Settings and not in the prlogging and explained in the documentation under the Appendix: Developer and Debugging tools

https://pdn.pega.com/documents/pegacall-configuration-and-operations-guide-cti-link-engine-avaya-aes-cti-7133-0

In this case remove the logging entry in the prlogging.xml file and configure the logging cia the console i.e. Designer Studio>Channel Services>PegaCall>Tools & Settings and click on the logging settings in the screen below.



 

This removes the double log entry.
 

Published August 22, 2016 - Updated December 2, 2021

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