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Support Article

System Name changes when we do update/upgrade

SA-655

Summary



PRPC 7.1.x is installed and system name is set to something other than the default of pega or prpc.  After upgrade or update to 7.1.6 the dynamic system setting for the system name has been changed to prpc.  

Error Messages



Not Applicable 

Steps to Reproduce



This is how you can reproduce ..

(1) Create an instance in 7.1.5 (or 4) and give a system name as “MySystemName”
(2) Run update using 7.1.6
(3) Look at the system name now (after update or upgrade) you will see the name as “prpc” when it should still be "MySystemName"

This is NOT limited to 7.1.6 as admin noticed this issue after previously upgraing to 7.1.3


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules. The upgrade script sets the system name to prpc as part of the upgrade/update and does not revert it back to the actual system name of the system.



Resolution



 In looking at the release notes for 7.1.6 this is a known issue and is slated to be corrected in a future ML.

These are the instructions from the release notes for how to get around this issue.

The upgrade process renames your system to “PRPC” and modifies any custom requestor rules in your application to use this name. After the upgrade completes, you must apply these changes to revert your system:

  1. Identify all custom requestor rules (browser, batch, app, portal) with access groups that point to prior versions of PRPC.
  2. Open the relevant access groups (for example, PRPC:Unauthenticated and PRPC:Agents) and update the name and version fields to point to the current PegaRULES application.
  3. Reset your system name to its original value. You can set the Dynamic System Setting prconfig/identification/systemName/default or use the Designer Studio > System > Settings > System Name landing page.
  4. Restart the system.

Published March 31, 2016 - Updated October 8, 2020

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