Support Article
Unable to connect SMA through Remote Connection
SA-8359
Summary
Unable to connect SMA through Remote Connection.
environment details:
Apache-Tomcat-7.0.52 (Application Sever)
JDK 1.7.0_40 (JVM)
Error Messages
Cannot connect to the server with specified settings
Failed to retrieve RMIServer stub: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectionException: Connection refused to host:
'your_host'; nested exception is: java.net.ConnectException: Connection timed out]
Steps to Reproduce
Configure SMA and use Remote connection.
Root Cause
JMX connection for SMA using remote connection requires JMX to be enabled at Tomcat level.
Resolution
Following JVM arguments are required for JMX:
-Dcom.sun.management.jmxremote.port=<jmx.port>
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false
Published September 18, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.