Support Article
Since upgraded to 7.2.2 browser often hangs and needs refresh F5
Summary
The browser is often hanging since upgrade to Pega 7.2.2. User are having to frequently refresh (F5) to get around the problem which happens in the user portals and DesignerStudio.
Error Messages
In Google Chrome Dev-Tools there are freqently error messages like this one at the time of the issue:
Websocket closed, reason: Connection was closed abnormally (that is, with no close frame being sent). - wasClean: false
pzevalharnessjson_12057459600.js!clientlogbase_11632504602.js!pzpega_ui_lib_provider_1191955478!peg…:721 Websocket failed on first connection attempt. Downgrading to long-polling and resending
http://xyz/prweb/PRPushServlet/!@d18bf7eaaa9…=true&Content-Type=application%2Fjson&X-atmo-protocol=true&_=1494937222781 Failed to load resource: net::ERR_CONNECTION_RESET
The Logfiles also show a large numbers of Etier Invocation exceptions:
2017-05-16 11:13:27,293 [p-bio-8009-exec-1023] [ ] [ ] [ ] ( web.impl.WebStandardImpl) ERROR - null: Unhandled error in ETier invocation
java.lang.IllegalStateException: Cannot create a session after the response has been committed
at org.apache.catalina.connector.Request.doGetSession(Request.java:3043)
at org.apache.catalina.connector.Request.getSession(Request.java:2415)
at org.apache.catalina.connector.RequestFacade.getSession(RequestFacade.java:897)
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Steps to Reproduce
It happens sporadically.
Root Cause
A defect or configuration issue in the operating environment. It appears to be a Tomcat 7 bug relating the use of a combination of a reverse proxy and Web Sockets introduced in Pega 7.2.2.
Resolution
Make the following change to the operating environment:
Upgrade to a later version of Tomcat (version 8 in this case).
Published July 27, 2017 - Updated October 8, 2020
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