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Support Article

User reports were not visible after upgrade to Pega7.1.8

SA-19625

Summary



After upgrading from Pega 7.1.6 to 7.1.8, user's reports are not visible under Report viewer under CaseManager portal.

Error Messages



No error messages. Just blank entries for reports.

Steps to Reproduce



1. Launch Case Manager.
2. Open Reports by clicking on the "Reports" link on the left-hand side of the portal.
3. Click on "All Reports" next to the "Search Reports" search-box.

Root Cause



In this case, a value of '0' for all records for pzClassType column in pr4_rule_vw table was noticed, which was the root cause of reported issue.
This column was not correctly populated during upgrade process.

Resolution



Following scripts helppopulate pzclassType and pzRuleSetVersionMinorPatch columns in pr4_rule_vw table correctly.

 
--------- Script-1 Starting ---------
          update RULES.pr4_rule_vw V set pzclasstype = (
          SELECT (CASE WHEN B.pyclassinheritance = 'true' AND B.pyruleresolution = 'true' then 0
          WHEN B.pyclassinheritance = 'false' and B.pyruleresolution = 'true' then 1
          WHEN B.pyclassinheritance = 'false' and B.pyruleresolution = 'false' then 2
          else -1
          end)
          from RULES.pr4_base B, RULES.pr4_rule_vw where V.pyclass = B.pyclassname
          AND B.pxObjclass = 'Rule-Obj-Class'
          AND B.pyClassType = 'Concrete'
          AND ROWNUM = 1
          )
          where pzclasstype is null
---------------------------------------------

 
--------- Script-2 Starting ---------
          UPDATE RULES.PR4_RULE_VW 

          SET pzRuleSetVersionMinorPatch =
          CASE
          WHEN pyRuleSetVersion IS NULL THEN '-1'
          ELSE SUBSTRING(pyRuleSetVersion, 4, 5)
          END
          WHERE pzRuleSetVersionMinorPatch IS NULL;
------------------------------------------- 


Reported issues are resolved after user executes these SQL scripts.



 

Published February 12, 2016 - Updated October 8, 2020

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