Support Article
Wait shape not waiting for all cases to be resolved
SA-38544
Summary
A Wait shape has been added to a flow to wait for all 'Initial Review' cases to reach a status of 'Resolved-Completed' before proceeding. The user has reported the flow is proceeding after only one 'Initial Review' case is resolved.
Error Messages
Not Applicable
Steps to Reproduce
Configure a Wait shape in the flow to wait for all 'Initial Review' cases to reach a status of 'Resolved-Completed'.
Root Cause
An issue in the custom application code or rules. There was only one 'Initial Review' case created at the time. So when the case was resolved, the Wait shape continued the flow correctly as all of the 'Initial Review' cases were resolved.
Resolution
The design was changed to create all of the 'Initial Review' cases when the parent case was created so the Wait shape will wait for all of them to be resolved.
Published June 1, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.