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Support Article

Work indexes display as unavailable on search landing page

SA-14612

Summary



In a multi-node environment with two indexing nodes, shutting down one indexing node can result in the indexes having a File Size as "unavailable" on the Search landing page (when viewed from the indexing node) that was not shut down. This indicates an issue with the index synchronization process between the two nodes.

The synchronization process depends on the Node or Node ID and File Location to remain unchanged on the Search landing page once it is set up and a link is established between the nodes. If the indexing name and/or file location is later changed, this will result in the Search landing page displaying "unavailable" for the File Size of that index process (Data, Work or Rules).


Error Messages



Not Applicable


Steps to Reproduce



1. Set up Search indexing in a multi-node environment with both Primary and Secondary Indexing nodes.
2. Change the Primary and Secondary Indexing Node details on the Search landing page.  Change Node Name, Node ID and file location (file location on both servers should be different) of the two nodes.
3. A reindex process will automatically kick off - there is no action to reindex the changed nodes.  When the indexing has completed, shut down either the Primary or Secondary Index nodes.
4. This should result in the "unavailable" File Size value for one (1) or more of the indexes (Rules, Data or Work).
Shutting down the Secondary Search Indexing Node results in the WORK index displaying "unavailable" for the Search Landing Page. The RULES & DATA Indexes display correct index file sizes. 


Root Cause



Both the Primary and Standby Index value changes on the Search landing page to a different node, node ID and index file location.


Resolution

1. Shut down all nodes
2. Delete contents of the explicitIndex folder so that all indices can be rebuilt
3. Delete the indexing node references from the pr_sys_statusnodes table. This table contains the current state of indexing for all nodes.  Since this issue occurred when switching primary indexing nodes, the previous entries were not updated to have a Resolved Status and indexing still attempted to occur on those nodes.
4. Delete the PegaRULES_Extract_Marker.txt file on all nodes to remove any cached entries on the servers
5. Start the Primary Search Indexing Node - wait for the node to completely start (for example, WebTier Initialization Complete)
6. Start the Secondary Search Indexing Node - wait for the node to completely start (for example, WebTier Initialization Complete). Repeat this step as needed for remaining Search Indexing Nodes
7. Log in as a Developer and Cancel any started Indexing (This is necessary to complete the startup or reset process)
8.  Begin the rebuilding of Rules, Data & Work Indices. Click "Re-Index".
9. Start each Non-Search Indexing Nodes - wait for each node to complete the startup of the Search Indexing (for example, 
Ends Initializing Search Infrastructure). Repeat this step until all nodes are started
10. In the Find Search box at the top of the Designer Studio page, search for one or more of each process indexed (Rules, Data and/or Work). Results should now be good on all nodes.  If not, repeat from Step 1.

Published November 19, 2015 - Updated October 8, 2020

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