Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Cannot remote connect SMA: No available router to destination

SA-15236

Summary



Pega is running on a managed Weblogic server and Admin needs to connect to Pega node through remote JMX connection in SMA.
The connection fails with an error.


Error Messages



Cannot connect to the server with specified settings
t3://your_host:your_port: Destination 127.0.0.1, your_port  unreachable; nested exception is: java.io.IOException: Empty server reply; No available router to destination

Stack Trace:
com.pega.jmx.ui.util.JMXClientException: Cannot connect to the server with specified settings
t3://your_host:your_port: Destination 127.0.01, your_port unreachable; nested exception is:
java.io.IOException: Empty server reply; No available router to destination
at com.pega.jmx.ui.util.JMXClientException.wrap(JMXClientException.java:49)
at com.pega.jmx.ui.action.AuthenticateAction.execute(AuthenticateAction.java:302)

Steps to Reproduce

  1. Add the following JAVA_OPTIONS to the managed server JVM : -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=8008 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false
  2. Configure SMA to use Remote JMX connection via the following URL : service:jmx:t3://your_host:8008/jndi/weblogic.management.mbeanservers.domainruntime
  3. Click on the node name on SMA

 

Root Cause



The remote JMX configuration steps are not applicable to Pega running on a managed Weblogic instance

Resolution

  1. Add the following JAVA_OPTIONS to the managed server JVM : -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=8008 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false
  2. Configure SMA to use Remote JMX connection via the following URL : service:jmx:t3://your_host:8001/jndi/weblogic.management.mbeanservers.runtime
  3. Notice the port number in the URL is not the remote JMX port but the regular http port for the managed server 8001 and the Mbean is ‘weblogic.management.mbeanservers.runtime’ instead of the ‘weblogic.management.mbeanservers.domainruntime’
     
  4. You'll get this prompt when clicking on the remote node on SMA.
  5. After entering valid Admin credentials (same as weblogic console credentials), you can connect to the node successfully.

 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us