Support Article
Email Listener going down
Summary
User has an Email Listener configured which polls the server every 15 seconds. Some times, the listener is going down with error count in System Management Application (SMA).
When the log files were checked at the time when error occurred, the reason implies to Socket Time out Exception.
When we restart the listener manually, the listener keeps running.
Kindly advise how to automatically restart the Email Listener?
Is there a way to configure some Agent which tracks the Listener status and restart it?
Error Messages
Caught exception while connecting to email server(s)
javax.mail.MessagingException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out;
nested exception is:
com.sun.mail.iap.ConnectionException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out
at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:569)
Steps to Reproduce
Issue is intermittent. So, could not reproduce it.
Root Cause
Incorrect sleep time observed when email listener fails to establish connection, due to incorrect calculation being performed by the core engine.
Resolution
purpose: email/maxRetry
owning ruleset : Pega-IntegrationEngine
Published January 31, 2016 - Updated October 8, 2020
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