Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Email Listener going down

SA-18428

Summary



User has an Email Listener configured which polls the server every 15 seconds. Some times, the listener is going down with error count in System Management Application (SMA).

When the log files were checked at the time when error occurred, the reason implies to  Socket Time out Exception.

When we restart the listener manually, the listener keeps running.

Kindly advise how to automatically restart the Email Listener?

Is there a way to configure some Agent which tracks the Listener status and restart it?


Error Messages


Caught exception while connecting to email server(s)
javax.mail.MessagingException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out;
nested exception is:
com.sun.mail.iap.ConnectionException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out
at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:569)


Steps to Reproduce



Issue is intermittent. So, could not reproduce it.


Root Cause



Incorrect sleep time observed when email listener fails to establish connection, due to incorrect calculation being performed by the core engine.

Resolution

 
Apply HFix-24902.
Description of the Problem
Incorrect sleep time observed when email listener fails to establish connection
Description of Changes
Increment retries only when there is a connection failure. Keep a static map to store the retries. Expose max retries via a DSS. 
purpose: email/maxRetry 
owning ruleset : Pega-IntegrationEngine

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us