Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Save, Delete or Commit has failed because lock is not held

SA-19532

Summary



Users sporadically receive an error "Save, Delete or Commit has failed because lock <lock name> is not held" when trying to resolve a work object.


Error Messages



Save, Delete or Commit has failed because lock <lock name> is not held


Steps to Reproduce



Click to resolve work object.


Root Cause



The goal time for the Service Level Agreement was set to zero and the service level agent had executed.

Resolution



Perform the following local-change:

Increase the goal time for the Service Level Agreement rule, so the agent will not try to process the item immediately.

 

Published February 12, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us