Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Search Returns Empty Results

SA-24120

Summary



The Pega search returns no results. The Search landing page shows index file sizes as "Unavailable."


Error Messages



Not applicable.


Steps to Reproduce



Not Applicable.


Root Cause



A defect or configuration issue in the operating environment. The system in the cluster are multi-homed. This means that they have at least two different IP addresses.

One of these is dedicated to the IT team and is not available for use by applications. The elastic search algorithm picked up this IP and was blocked. The hazelcast algorithm selected a working IP.


Resolution



Perform the following local-change: 

The following prconfig setting allows the IP address to be set to an appropriate value.

<env name="indexing/distributed/network/host" value="your_IP_address"/>
 

Published June 9, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us